1. Introducing the smashing new Team FIAT T-Shirt !! To order yours click here : Team FIAT T-Shirt

feeling a slight lack of power after first service.

Discussion in 'Engine Compartment' started by drgopusankar, Nov 1, 2011.

  1. hello everyone,

    after the first service of my punto mjd active, I have noticed that the car has become smoother, but shows a slight decrease in power. Before first service the car would move with out throttle in the first,second and third gear with considerable speed. but now it has become slightly sluggish. It would move but with out that much former speed. The idling rpm now shows less than 1000. please help.
  2. Srini

    Srini Regolare

    Messages:
    468
    Chennai
    First service is primarily done only for top up's and checking for any loose stuff which would have developed. Usually nothing is changed unless troubles are spotted. Can you check with TASS if they did anything?
  3. I called Mr. ratheesh, my SA and he told that nothing is changed. he says that is normal. idling rpm is around 900 only, for punto. But why my punto's idling rpm was 1000 before first service?
  4. Italia-Linea

    Italia-Linea Staff Member Janitor

    Messages:
    2,123
    Pune
    all mjds idle at 900 rpm.

    can you do one thing. please disconnect the battery for 20 min and reconnect.

    after servicing the engine has new oil and cleaned air filter. let the ecu take an immediate account of this.

    let me know your experience after this.
  5. Tron

    Tron Superiore

    Messages:
    667
    Mumbai
    amit, he had done FIRST service, so no oil change.
    @drgopusankar, how many kms your car done till today? Please let us know that so we can help.
    As you said it was your first service, your airfilter must be stock one.
    Do DIY, grab a no.7 spanner, open up your airfilter casing & clean your air filter. If you can, blow pressurised air through it.
    Cloged airfilter makes lot impact on car's power.
    Follow italia linea's advice & remove negative terminal for 20min. This will help too.
    +1
    If you are driving in heavy B2B traffic change your engine oil & oil filter at 6500/7000kms.
  6. @ Italia Linea .. thank you for your advice. my car has undergone first service only. will do as you suggested.

    @ tron. thank you. I will do as you suggested and will update the thread.

    ---------- Post added at 10:19 PM ---------- Previous post was at 07:20 PM ----------

    hello tron,
    my car has covered only 6898 kms so far
  7. Srini

    Srini Regolare

    Messages:
    468
    Chennai
    Ist service at 7000 KMS? Isnt it at 3000 or 5000 KMS?
  8. first service was at 5000 kms. after that I noticed this. the car has become smoother, but a bit sluggish. the thing I mentioned is that, the speed of the vehicle in first, second and third gear with out throttle has come down .
  9. hello,
    I cleaned the air filter also. but did this only after disconnecting the neg terminal for 20 min.. Now after having done air filter cleaning, is it necessary again to remove neg terminal for another 20 min. Pardon me, if I am wrong.
  10. Italia-Linea

    Italia-Linea Staff Member Janitor

    Messages:
    2,123
    Pune
    no need to again disconnect if you have not driven your car much after ecu reset.

Share This Page