1. Introducing the smashing new Team FIAT T-Shirt !! To order yours click here : Team FIAT T-Shirt

Failure to start and showing EBD and ABS failure of my new linea mjd

Discussion in 'Electrical Systems' started by lakshminandan, Sep 22, 2015.

  1. lakshminandan

    lakshminandan Amatore

    Messages:
    55
    North Lakhimpur
    assam
    Linea 1.3
    @Umesh Kumar the engine is giving cranking sound but not firing up. When the key is rotated to MAR position, the dashboard lights glow and audio system works, but the head lights, fan, and wiper don't work. Then after sometime EBD, ABS failure, brake fluid insufficient warning show in the MID. I full charged the battery yesterday and tried to start but it didn't work. Then I called fiat helpline number, he asked me to push start which I did but was not successful. After that he suggested to jump start the car, which I am going to do now. I also called the FASS at Guwahati to send technician to my location. But they told that they won't be able to send. Instead they asked me to tow my car to Guwahati which is 500 km away. And they seems least interested to solve the problem of my car. I m in a great dilemma what to do.Also after door sill job I could not start the car even once. This problem came out since I did this.
    Last edited: Sep 24, 2015
  2. Sujit508

    Sujit508 Amatore

    Messages:
    233
    Bangalore , Karnataka
    Bangalore
    Retro / Classic FIAT
    I do not have experiance of the Immobilizer feature in fiats. it may be due to immobilizer as well. Other fiatians might be able to give more inputs on this.

    But as per your observation on heads lights, fan and wiper not working. Are you sure, all the connectors were fitted back correctly by the accessory guy, (If they were disconnected). Also the next thing would be look at the Fuse box(Right of the steering) , There are separate fuses for these, Check if they have blown. If yes, then there was a Short Circuit somewhere. leading to fuses blowing up.
  3. lakshminandan

    lakshminandan Amatore

    Messages:
    55
    North Lakhimpur
    assam
    Linea 1.3
    The jump start also didn't work.Technicians from both hyundai and maruti came to help me but they also couldn't solve the problem. Fuses were checked but they told all were okay. So I have decided to tow the vehicle by a trailer from a maruti dealer to Guwahati.I contacted at fiat helpline number, they told that Rs 2k will be reimbursed.
  4. harryaviator

    harryaviator Regolare

    Messages:
    341
    kochi
    kochi
    Linea 1.3
    try checking outthe immobilizer switch before getting it towed. underneath the car
  5. lakshminandan

    lakshminandan Amatore

    Messages:
    55
    North Lakhimpur
    assam
    Linea 1.3
    Can you please tell me the exact location? Can it be reset?
    Thanks
  6. Umesh Kumar

    Umesh Kumar Timido

    Messages:
    23
    Trivandrum
    Linea 1.3
    Never heard about a immobilizer switch. But there is an FPS reset switch in Linea near/below the glove box lid's left side.

    Check the fuses in the dashboard. Did he tamper the wires under the steering console or the ones near the OBD port?

    Capture.JPG
  7. lakshminandan

    lakshminandan Amatore

    Messages:
    55
    North Lakhimpur
    assam
    Linea 1.3
    Issue resolved. At last FASS decided to send their technician along with the diagnostic tool. After trying for 4 hours he detected the fault. The culprit was a loosely connected coupler at the fuse box near the steering. Thanks for the help and support brothers.
    Cheers.
    Umesh Kumar and pabhishek like this.
  8. harryaviator

    harryaviator Regolare

    Messages:
    341
    kochi
    kochi
    Linea 1.3
    Had to be a very minor issue. lucky that it got resolved and saved you a lot of trouble and moolah!
  9. lakshminandan

    lakshminandan Amatore

    Messages:
    55
    North Lakhimpur
    assam
    Linea 1.3
    Yes I was lucky that the issue was minor. The local mechanic had not fitted the coupler properly. So ABS & EBD failure symbols were coming. Otherwise towing charges only could have cost around 10k. FASS charged 400+350+2000(labour charge+diagnostic tool charge+off-road charge) in addition to transportation, fooding & lodging of the technician. Is the off-road charge ok?
  10. Rohan Goenka

    Rohan Goenka Timido

    Messages:
    4
    Indore
    Grande Punto 1.3
    FAILURE TO START AND SHOWING EBD AND ABS FAILURE OF MY Punto 1.3 MDJ 2011 , It won't crank as well . Yesterday I mistakenly cranked it n the car was in gear and it took a push like it happens when we do it right after that it happened . Please help team what to do ??
    Last edited by a moderator: Aug 14, 2016

Share This Page