1. Introducing the smashing new Team FIAT T-Shirt !! To order yours click here : Team FIAT T-Shirt

ECU/ECM reset procedure ?

Discussion in 'Electrical Systems' started by Sat-Chit-ananda, Jan 17, 2012.

  1. theblack

    theblack Esperto

    Grand Prix ???
    I'd be a satisfied driver if i can overtake a bullock cart in Bangalore :)
  2. @thebalck, give a try there is nothing to loose other than the virtual numbers in the ECU memory:)

    ---------- Post added at 08:18 PM ---------- Previous post was at 01:18 PM ----------

    Engine was bit rough for two day but today it has become lot smoother but I am loving the acceleration.
  3. Shadowfax

    Shadowfax Regolare

    hello all,

    my 90 hp mjd is misbehaving a bit these days specially after the 15 k service, the noted symptoms are as follows.
    mileage has dropped to approx 14
    engine noise has gone up
    pickup is sluggihsh
    should I try following this procedure?
    will this affect the stock stereo of the car....as in will it ask for the code?
  4. Your 90HP is right candidate to try this,there will not be any issue with stock stereo. remember idling for 5 minutes after connecting back the -ve terminal.
  5. gurjinder

    gurjinder Staff Member Janitor

    If the engine is warm enough, the car can be driven right away. The earlier the better.

    It's best to do this when the engine is already at its operating temp, so that we don't have to waste time idling the engine.

  6. I don't know when i did that for the first time my car was sluggish,also the recommendation is to idle.
  7. Italia-Linea

    Italia-Linea Staff Member Janitor

    Are you removing your negative terminal to reset? Correct way is to remove positive only so that the residue current is discharged through ground. Just turn the ignition key once after removing the positive terminal. All the residual current goes and ECU resets instantly.
  8. ENKI

    ENKI Esperto

    What you are referring to a complete different issue. Car sluggish, noise gone up, dropped FE. Take it back to TASS. ECU reset has nothing to do with it IMO. It should sound better/good FE & better pick up at least you had before service. Pls check your engine bay. These guys are horrible at times. Pls check if have they really changed air filter/engine oil/coolant, any leakage or loose inlet pipes/ducts etc. Check all the aluminum clamps if they are perfectly tightened. ECU reset will yield some 2-3 % difference, what you are talking about looks some carelessness on part of TASS.
    Last edited: Mar 22, 2012
  9. Shadowfax

    Shadowfax Regolare

    I resetted the ecu by disconnecting negative terminal

    the odo is blinking now and b&m is not working
    nor is stereo controls pls help

Share This Page