1. Introducing the smashing new Team FIAT T-Shirt !! To order yours click here : Team FIAT T-Shirt

EBD failure msg intermitent

Discussion in 'Electrical Systems' started by manojnambiar, Oct 10, 2013.

  1. manojnambiar

    manojnambiar Novizio

    Messages:
    42
    Bangalore
    Hi all

    On my Punto MJD since past few days, during my first start of the day, EBD FAIL, CHECK MANUAL msg is dispalyed, with no brake warning annunciator glowing. and this problem is intermittent and not on every start or nor every day.... dont know whtr its an actual problm or not..?... did anybdy experience similar problem..?...please do share....
  2. vj_v1

    vj_v1 Superiore

    Messages:
    933
    Hyderabad
    Dying battery. Try a recharge. If that does not help, you'll need to get a new one.
  3. limraj

    limraj Superiore

    Messages:
    915
    Trivandrum
    Linea 1.3
    i saw this warning when driving under heavy rains. but, the warning stopped after I had a re-start of the car.
  4. faraz784

    faraz784 Timido

    Messages:
    11
    Faridabad
    try changing battery

    Me faced the same problem on Punto MJD. A change of battery resolved the issue.
  5. me_at_fiat

    me_at_fiat Regolare

    Messages:
    258
    Mumbai, Pune
    None other than dying battery. Change it ASAP. Punto comes with DIN50 but while buying new battery go for Ameron Din55.
  6. manojnambiar

    manojnambiar Novizio

    Messages:
    42
    Bangalore
    Thank You bros, shall go for change of battery, even my immobilizer / car protection system failure light remains on after engine start, but this too is intermittent, not on every start, can anybody suggest a good battery for Punto 1.3 MJD and what would be its cost?
    Last edited by a moderator: Aug 6, 2016
  7. Hari baskaran

    Hari baskaran Timido

    Messages:
    6
    Dharmapuri
    Punto Evo 1.3
    Hi friends..

    Today while starting my Punto Evo after parking in a ramp, ebd failure message popped up while I turned on and it disappeared as soon as I cranked up the engine. I turned off and restarted again, but dint get any EBD failure popping up, also no warning lights came up, mine is a 75hp emotion variant 7 months old and clocked 12.5k kms. Iam worried about this, since I have planned a trip this weekend about 600km up and down. Kindly help me.

    Mod Note : Kindly avoid typing in SMS lingo. Merging posts with existing thread.
    Last edited by a moderator: Aug 6, 2016
  8. basavaraj koti

    basavaraj koti Novizio

    Messages:
    28
    bangalore
    May be a loose battery connection.
    Any how get it checked at FASS, any issues and under warranty, they'll replace.
    PradeepM likes this.
  9. PradeepM

    PradeepM Staff Member Janitor

    Messages:
    705
    Hyderabad
    Linea 1.3
    Hello Hari,

    Did the car stall when you are getting it up the ramp or the error popped up when you turned the ignition on when you wanted to move the car after sometime of parking it on a ramp. From what I understand this may be a warning at the moment and no need to be too bothered about it. You can get the error log cleared when you visit the FASC next time. I don't see anything much to worry. At this point I don't suspect a battery issue, unless your car is very sparsely used which I don't think is the case referring to the odo reading. Keep an eye on the same and in case this issue reoccurs frequently you can get the battery checked at FASC and call for a replacement on need basis.


    Cheers,
    Pradeep.
    Last edited: Aug 6, 2016

Share This Page