1. Introducing the smashing new Team FIAT T-Shirt !! To order yours click here : Team FIAT T-Shirt

EBD and ABS failure while driving

Discussion in 'Safety First!' started by Allen, Nov 17, 2021.

  1. Allen

    Allen Timido

    Messages:
    3
    Hubli
    Punto Evo 1.3
    Hi all,

    I am getting Ebd and abs failure on my punto evo 1.3 when I’m driving at a speed over 100kmph, when I stop car n restart engine there won’t be any errors, again if I drive over 100kmph I’ll get Ebd n abs error can anyone help me how to solve the issue
     
  2. limraj

    limraj Esperto

    Messages:
    1,357
    Trivandrum / Bangalore
    Linea 1.3
    Please take it to FASS and ask them to scan for error codes.
    Most likely one of the ABS sensors have gone. They would identify which one and then replace it. It is very risky to drive with a failing ABS - you lose control while panic braking.

    ABS/EBD error may also pop up when driving in the rains for prolonged periods or when battery is weak.
     
  3. Allen

    Allen Timido

    Messages:
    3
    Hubli
    Punto Evo 1.3
    I have new battery in place also checked in FASS , they diagnosed and said abs sensors are fine, even they are not able to find out the issue and this problem is very wiered.. since Ebd and abs is failing only when I cross 100kmph while driving … if I’m driving my vehicle in city limits I.e driving below 100kmph then I’m not getting any errors on my vehicle..
     
  4. limraj

    limraj Esperto

    Messages:
    1,357
    Trivandrum / Bangalore
    Linea 1.3
    I once faced a similar problem. ABS sensor error will come and go. FASS replaced the sensors one by one and then found the failed one. Once it was replaced, the error did not occur again.
    However, for me, the ABS error was not linked to speed. It used to come in lower speeds, driving in city too.

    In your case, if FASS says ABS sensors are fine, then I'm clueless.
     
  5. Allen

    Allen Timido

    Messages:
    3
    Hubli
    Punto Evo 1.3
    Thank you so much for your reply, I am trying to fix this issue…
    Let me know if you have any ideas to solve it…
    I will surely put down my findings/ solutions here once im able to fix the issue

    thanx
     

Share This Page