1. Introducing the smashing new Team FIAT T-Shirt !! To order yours click here : Team FIAT T-Shirt

check engine warning

Discussion in 'Engine Compartment' started by renjithlal, Jan 3, 2015.

  1. renjithlal

    renjithlal Novizio

    Messages:
    43
    Bangalore
    Bangalore
    Punto Evo 1.2
    rhai everyone, I got my. New. Punto. 1.2 only on 28.12.14 -last Sunday. It is only 6 days old. From last day when I turn on the engine, it gives a beep sound & shows check engine message. And sometimes when. I press accelerator engine not revs & tacho stand still. Immediately called the service guy. He told not to use the vehicle & assured they are on the Way. Fingers crossed & really worried. Share any such experience..
  2. Saket Sidana

    Saket Sidana Regolare

    Messages:
    491
    Delhi NCR
    Linea T-Jet
    O man, this is not good by Fiat. Don't get too much worried or think too much till they provide a reason to you. Could turn out to be some minor sensor/wiring issue. It's covered under warranty though. Do get full details on the issue and post it here so that fellow members can share their insights.
    prabhjot and renjithlal like this.
  3. pabhishek

    pabhishek Esperto

    Messages:
    1,379
    Oslo
    Pune
    Linea T-Jet
    Well, that's not good, but as saket told,, may be some loose contact. Keep us posted on the developments.
  4. renjithlal

    renjithlal Novizio

    Messages:
    43
    Bangalore
    Bangalore
    Punto Evo 1.2
    most of The day I was in touch with the service centre..Even late till afternoon they diagnose the issue specifically. Only thing they could tell that it could be a sensor issue & is electrical. He says the amount of pressure applied to accelerator is not being senszed for adequate fuel injection. Hence tacho not responding to accelerator Engine and all running fine. After refitting & fitting the problem still persists. Tomorrow is holiday. Hopefully waiting for positives Monday.
    prabhjot likes this.
  5. Ganges

    Ganges Esperto

    Messages:
    3,121
    Driver Seat _/
    :
    Grande Punto 1.3
    What kind of quality test does these people carry around in the factory ? Thats really strange to see these on brand new car.

    Please raise a question to FIAT India about the "Quality" of testing.
  6. Jotinder

    Jotinder Regolare

    Messages:
    308
    New Delhi
    Linea 1.3
    If check engine light is on, it doesn't allow to go beyond 2500rpm as a precaution
    Saket Sidana and Ganges like this.
  7. Ganges

    Ganges Esperto

    Messages:
    3,121
    Driver Seat _/
    :
    Grande Punto 1.3
    Thanks Jotinder for the info, never knew about this information.
  8. renjithlal

    renjithlal Novizio

    Messages:
    43
    Bangalore
    Bangalore
    Punto Evo 1.2
    Latest update, service centre is telling it is only a loose connection. However they have not fixed it so far. I wonder, if it is only a loose connection, why they take almost 2 days...still not fixed. They have no realistic explanation for this. What they are telling, they were getting an error code from OBD, which they were unable to diagnose. So they forwarded it to FIAT Technicians. According to FIAT instruction once/twice they tried to fix it, but the error message was still re-appearing. When I contacted late this evening..reportedly the car is on a test drive (a long test drive as they put it), to ensure that the error is fully fixed and is not re-appearing. Once it is confirmed that the error is not coming, they will deliver the vehicle. I don't know, what these people are telling is true/not? Right from the beginning they deliberately maintained that there is no major issue, no vehicle complaint (read no manufacturing defect), there is no mechanical error, but the error is only electrical (one would wonder whether faulty electric -wiring etc , is that not manufacturing defect, or could be seen apart from the vehicle). They are telling as if it is a non-issue and has nothing to do with Fiat. I don't know, apart from the manufacturer who else is responsible ? So one more day is over...wait continues for another day. Still fingers crossed what is in store for us...tomorrow?
  9. Anup

    Anup Regolare

    Messages:
    303
    Bangalore
    Bangalore
    Grande Punto 1.3
    There are a couple of Sensors like TD Sensor, Map Sensor which can easily go wrong and sometimes the ECU reader would not exactly pin point if either the Map/TD sensor is hone, I would suggest you to check with the SA if they have checked with these 2 sensors, all they have to do is put in a new sensor and crank the car.
    Also ask if they can swap a ECU with a new one and see if that's working.
    Sometimes water can sweep inside and it can cause the exact issue, my friend's old GTX had the same issue after the SA had done washing the car, later found water was the cause of the issue.
    mangeshtendulkar likes this.
  10. ccprakash

    ccprakash Regolare

    Messages:
    268
    Bangalore
    I have exactly faced the similar kind of issue when i bought my car in 2011. From the day 2, i kept my car in KHT. They took 2 days to diagnose the problem and to test the vehicle. But From then i didnt face any problem till now. Iam very much satisfied with the work delivered by KHT that time.

Share This Page