1. Introducing the smashing new Team FIAT T-Shirt !! To order yours click here : Team FIAT T-Shirt

Check Engine Message

Discussion in 'Electrical Systems' started by atulalvenkar, Aug 27, 2010.

  1. ccprakash

    ccprakash Regolare

    Messages:
    268
    Bangalore
    thanks cyberdoctorind and vIjAy_kHaSa for your info. I have noted down all the points you mentioned, i will check with TASS ppl today.:D
  2. bhai

    bhai Esperto

    Messages:
    1,185
    Ahmednagar
    Grande Punto 1.3 90 HP
    Problem name is "limp mode of ECU".

    RPM remains @1500 RPM
    Car goes in limp mode due to faulty TPS (Throttlr position sensor) , faulty ECU or serious engine error.

    Keep update. Because it's a first car on TFI which is going in limp mode
    2 people like this.
  3. ccprakash

    ccprakash Regolare

    Messages:
    268
    Bangalore
    Still they are inspecting the issue with ECU examiner. They have taken my electrical,mechanical and audio code. In the initial inspection they found the faulty clutch. Iam very unlucky, from the day 1 iam facing the problem. Still i love FIAT. Hoping for the best service from KHT. Will post you the detailed description once i got the vehicle back.

    One more thing, why the engine compartment is getting heated so much? Earlier i have maruti astar, that did nt generated that much heat.

    ---------- Post added at 08:01 PM ---------- Previous post was at 05:08 PM ----------

    They have done the ecu revamp and everything workfine for some time.but the problem arises again.They have checked the cables, scanners and almost everything. Ecu examiner also not able to detect anything. Please suggest my future course.
  4. bhai

    bhai Esperto

    Messages:
    1,185
    Ahmednagar
    Grande Punto 1.3 90 HP
    No ECU error still problem petsist?

    Very unique problem.
    Last edited by a moderator: Jan 5, 2012
  5. vIjAy_kHaSa

    vIjAy_kHaSa Esperto

    Messages:
    1,353
    Panchkula
    The ASS might be hiding some facts from you. Were you present when they checked for error codes in the ECU. Believe me the ASS people are nuts the new ASS in Panchkula reset service reminder in my car by selecting Punto 1.2 whereas my car is Linea 1.3 MJD.
    Make sure that they select Grande Punto Internatinal in the car and 1.3 MJD Magnetti Marelli 6F3 as the ECU while reading error codes from the ECU.
    The ASS would also have been having workshop manual of cars in whose Electrical Section there would have been complete information on how to detect a faulty wire , sensor, ECU etc with the help of multimeter by checking voltage and resistance without the help of Examiner.
    Ask the ASS to swap the ECU from TD vehicle if that solves the problem, they can order a new ECU for your car and then replace the same with TD car ECU to new ECU.
    Last edited by a moderator: Jan 5, 2012
    1 person likes this.
  6. sungoa2010

    sungoa2010

    Messages:
    2,878
    Goa
    A software updation may solve the issue. eReport it to Fiat. In my case similar problem were there.The issue resolved after
    updating the ECU. Have you tried disconnecting the battery terminals? Does your problem occuring only in cold start?
  7. ccprakash

    ccprakash Regolare

    Messages:
    268
    Bangalore
    Yes suguna, they have tried all the ways, disconnecting battery terminals, updating the ecu.
    Just now i got a call from service person(Velu-KHT motors) bangalore. He said problem got rectified. They have done the trail run for 15 kms it seems. They didnt find the issue now. Iam getting my car back tomorrow.
    He mentioned some cable wire which connects to the ECU got damaged. Will let you know the exact problem tomorrow.
    By the way i have got the good service at KHT motors Bangalore instead of from AADYA motors banglore(this is where i booked my vechicle).

    Thanks for your support.
  8. Ravi

    Ravi Staff Member Janitor

    Messages:
    6,001
    Bangalore
    Grande Punto 1.3
    Certainly not unique problem, have a look at this http://www.teamfiat.co.in/engine-co...ine-error-ignition-indicator-permanently.html. But owners have not updated after issues resolved.
    One more similar thread - http://www.teamfiat.co.in/engine-compartment/2782-check-engine-error-punto-mjd.html


    Do update http://www.teamfiat.co.in/service-center-reviews/1192-kht-motors-bangalore.html thread with service experience with KHT.
    Last edited: Jan 5, 2012
  9. ccprakash

    ccprakash Regolare

    Messages:
    268
    Bangalore
    Sure ravi, will update my experience with KHT.
  10. ccprakash

    ccprakash Regolare

    Messages:
    268
    Bangalore
    Hi Fiatians - I have got my car back yesterday after 7:30 PM. I checked with the service person. He told me that they replaced total cable unit in the engine compartment as some of the cables got damaged. He showed me the faulted cables. I have asked them to TD the vehicle on the highway. They did it and everything is working fine.
    Even i went on some ride on the Bangalore-Tirupathi highway, and the experience is awesome. I never know when the speedo is touching 100. Even 100 also car is pretty stable.
    This is new experience to me(As i was driven aStar earlier).

    Happy miles ahead. Thanks you once again.

Share This Page