1. Introducing the smashing new Team FIAT T-Shirt !! To order yours click here : Team FIAT T-Shirt

Check Engine Message

Discussion in 'Electrical Systems' started by atulalvenkar, Aug 27, 2010.

  1. J Ravi

    J Ravi Esperto

    Messages:
    2,293
    Bangalore
    Thank god, the issue was resolved amicably at the earliest. I read a horror story of a member in another forum was forced to give a post-dated cheque to a Honda dealership to change a starter motor under warranty as the manufacturer was yet to decide on it!
  2. jumu

    jumu Superiore

    Messages:
    969
    Chennai
    Atul

    Whether FIAT is forthcoming to replace parts under warrranty or not, my concern is the instant failure of these sensors the moment they come in contact with water. FIAT will have more of this headache in future and this rainy season with the global warming pouring down more than usual rains. Why doesnt it happen in the LInea mjd. VP , your comments please. ::D

    Is it the location of this sensor the problem or is the sensitivity of the sensor to moisture the issue ?. Fiat needs to set it right at the earliest. I got trapped in a puddle just once and this happened, so I am dreading to think of the wading I will have to do on waterlogged streets of Chennai city especially T.Nagar

    Abdul
  3. VahanPujari

    VahanPujari Staff Member Janitor

    Messages:
    2,303
    Mumbai
    Well, the place where I live, the exit road to the main road is low lying. So even if it rains not so heavily,the water starts clogging. 2-3 times I drove the car thro' water level which is almost 75% of the wheel level or more (more than 75% of wheels submerged in water) but never faced any issue. I must say that I drove in 1st gear with very high rpm's, more than 5000 rpm's I think.

    Having said that, water always presents a danger to all electronic items including sensors.
  4. Gmittal

    Gmittal Amatore

    On friday When I reached home after office I found my car's rear wiper was broken and hanging on the rear windscreen, might be some kid tried to play with it. Took it to TASC on saturday and got it replaced FOC under warranty. :wow :wow :wow
    I was not having any clue in my mind to get it replaced under warranty but I got surprised when SA told me that it can be replaced under warranty. :dancing :dancing :dance :dance
  5. Jumu the water level was bit high .. being night and no lights i could not gauge the level add to it that our CM saab was somewhere nearby and the police were after me to move on .... it was my mistake i should not have driven it through that high water level .. when i was in middle of the puddle i realized how high the water was and it's force....
  6. On mumbai-pune expressway I got this error first time month back; I stopped the car and started again to see that error. On the next day I did not see the error again. On weekend when I visited Balaji Service Center @ Thane; those guys mentioned its not hard failure; could be some electronics issue; need more time for repair.
    I was really busy then and was on the long trip with family. This error popped up again. I went to Tata-Fiat service center @ Dhule and they too examined again with Examiner and same result.

    Error was something like this
    1. wrong signal to cylinder #

    On both occasions when this error popped up speed was ~ 110.

    After that I got this error again after 3 weeks again on express way. speed was ~100

    Has anybody faced this issue.
  7. looks like loose connection with the sensors or not enough pressure going into the cylinders.
    get it checked as TASS. it might take time but get it fixed.

    never been on that part of the country is the road steep or flat like racetrack or airlane runway?

    it was discussed somewhere that this meesage was seen when climbing steep roads.

    click HERE.This might be useful
    Last edited: Jun 21, 2011
  8. gurjinder

    gurjinder Staff Member Janitor

    Messages:
    3,989
    Punjab
    Does seem like an electronic component acting funny.

    Didn't the Examiner pinpoint which part in particular was causing this error code? Do you have the error code that the examiner may have given out?
  9. I had this issue, it was traced to Common Rail pressure sensor connector,which was little loose.
    -Sat
  10. Thanks, I'll check that

    I've to see that again in Examiner.

Share This Page