1. Introducing the smashing new Team FIAT T-Shirt !! To order yours click here : Team FIAT T-Shirt

Check Engine Message

Discussion in 'Electrical Systems' started by atulalvenkar, Aug 27, 2010.

  1. rudresh

    rudresh Regolare

    Messages:
    264
    Hyderabad, India
    Yesterday due to heavy pouring in Hyd, i had to cross several water logged streets, but no stalling/waiting there, or nothing scary water level either. Today morning when I turned on the engine I saw the engine check light. Drove slowly to office ~6kms. Now the the problem in hyd is on 6th Tejaswi is opening new service center and they have stopped taking FIAT cars in old service center. I am kinda worried.

    What are the test I should do to check if there is a turbo failure or not? I did not notice any unnatural engine noise either. Should i take it to highway and have some 100+ runs for tests?
  2. vIjAy_kHaSa

    vIjAy_kHaSa Esperto

    Messages:
    1,352
    Panchkula
    No with Check Engine light ON you shouldn't drive your car much as one doesn't know what the error actually is. It can be as simple as a bad sensor, turbo hose pipe but you never know what critical component might have been damaged without connecting Examiner and reading codes specified. Drive as carefully as you can to ASS and leave it for diagnosis.
    Last edited: Apr 4, 2013
  3. deba

    deba Amatore

    Messages:
    102
    Itanagar, Arunachal Pradesh
    itanagar
    Grande Punto 1.3
    Last month on the ghats i got stuck in a muddy slush and the car had to be pushed out and the MJD engines got a real workout. As it was raining there were spools of water in the road with the tyres splashing water on the hot engine. Suddenly after driving for about 6-7 kms the engine check lights started glowing, i could feel the car losing some power too. I stopped the car for sometime and restarted but it didnt go. Drove slowly for another 10 kms or so stopped the engine for about 5 mins and restarted, and the check engine light was gone and the engine felt good again.
    The car has been driving smoothly without any problems since then (20 days or so) and the engine check light has stayed off. I just want to know if there is something to worry about or was it some electrical glitch? Pls need help as the TATA dealer people seemed very vague and confused in their explaination.
  4. PatchyBoy

    PatchyBoy Esperto

    Messages:
    2,438
    Bangalore
    The answer is actually hidden in your question. Get FASS to connect to OBD and check for stored errors and you will know why you got that error.

    20 day, smooth driving, error did not come back - I would say forget it. The car is fine :D

    Rajan
    3 people like this.
  5. I am facing the same issue. My car is at FASS center and they are not able to diagnose the case for last 3 days.
  6. deba

    deba Amatore

    Messages:
    102
    Itanagar, Arunachal Pradesh
    itanagar
    Grande Punto 1.3
    @Patchyboy Yeah that was my first guess too, because of the water splashing on the hot engine but i want to be sure. But the TATA guys told me maybe i was driving wrecklessly as the car was only 9 months old and relatively new (12000kms) so i shouldnt be taking it to such places plus their ECU monitor or something they said was out for repair. Anyway Thanks mate i hope car is fine.
    Last edited: Jul 10, 2013
  7. gurjinder

    gurjinder Staff Member Janitor

    Messages:
    3,989
    Punjab
    Well, i wonder what gives them the right to tell you how & where to drive the car or not. It is your car, bought with your money and you are free to drive it anywhere.

    Also, unless you slam through pools of water at 100+kmph, there isnt much chance of water splashing on the engine. The wheels wells are almost sealed.

    When the roads are wet, drive slow and smoothly. Always.

    Cheers.
  8. deba

    deba Amatore

    Messages:
    102
    Itanagar, Arunachal Pradesh
    itanagar
    Grande Punto 1.3
    Thats what i felt their answers were just about evading the problem and shifting the blame :mad:, so i needed the help from you guys. The roads there isnt that good and maybe i was doing 60 or 70 tops, so no problems there then?? Thanks mod.
  9. ENKI

    ENKI Esperto

    It has happened to me once. Water-logging in this part generally attract headlines on news channels and papers due to poor drainage under flyovers. I never skip my office/home due to water logging and touch-wood managed to escape any big issue so far. Last year, it was around 9:00 PM returning home and heavy rain was in progress. It really got scary for a car when i misunderstood the level of water (Trusting and tailing a bigger vehicle like bus or truck, that can escort you to some deep waters!!). You don't have option to stop and reverse because there is another truck and lot of cars behind you, many of them already stalled:A. Front tires almost immersed in water and i was literally chewing my heart. Just as it got out of water (like it was hell bent not to stall in water), it stalled. Had to push it to the road side with random bad thoughts like water into air-filter and what not! Left it for some 30 minutes because whenever i switched it on, there was CHECK ENGINE light (they say that you shouldn't start a car if stalled because of water logging, that could lead to engine seize if water manages to get inside air filter). I checked on my own into engine bay but everything was wet obviously. I couldn't make out if water has gone inside. Seeing around that there are numerous other vehicles stalled like me, rain falling in buckets, people charging insane amount (Rs. 500 for a push to get out of water). Sensing no chance of any help, gathered some courage finally in "Go to Hell" manner and started cranking it. It "cranked awfully more than normal" but it started none the less, once moved it started giving those little jerks. I decided to stop at any workshop midway but it was just too late for that (around 11:30 PM). Again felt "To hell with", stopped it somewhere and revved it to full throttle in neutral for 3-4 mins and switched it off. Smoked a cigarette and cranked it again, it never felt better. No issue after that but i will surely take care tailing trucks/buses into water (because you never know if it is escorting you into a lake).

    I think it could be some moisture into sensors or something like that creating false alarm. If it was not range rover kinda mud, Going through shouldn't be a problem. Though Punto is not meant to be a boat, but i am sure the way it's engine bay is sorted out with isolation and protection for everything, it will be the last car to stall.
    Last edited: Jul 10, 2013
    3 people like this.
  10. Abhi_shake

    Abhi_shake Timido

    Messages:
    1
    Vadodara


    I also got engine check warning on display and yellow engine light glows in my GP 1.3 Emotion pack after ~250km driving on highway but I continue my driving, after glowing the yellow light I drive it 150km safely. but next day when i start the car yellow light & Engine check warning automatically goes off, I cant understand what happened to it? after driving ~200km it comes again n i drive with it further 200km with no issue. Next day i starts the car to go to the Fiat service station, again warning & yellow light goes off. I explain the problem to service adviser at Bhaskara Auto (Vadodara)....and SA said they will fix it same day, when i receive my car the told there is no issue, your car is ok....
    Next day I drove my car to Mount Abu, yet again same prob. after 150-200km. During the trip next day again it goes off..... im afraid what to do???

Share This Page