1. Introducing the smashing new Team FIAT T-Shirt !! To order yours click here : Team FIAT T-Shirt

Check Engine Message

Discussion in 'Electrical Systems' started by atulalvenkar, Aug 27, 2010.

  1. fiat_fan

    fiat_fan Amatore

    Messages:
    185
    Calicut
    No, They didnt show me the ECU scan results.. Today I was little bit angry towards them as I have to get the car for an urgent trip..They did replaced turbocharger .. now I dont know wat will happen as We are going to our home town Calicut 400 km from here. Hopes that the issue is sorted out this time as Its the 3rd attempt!!!!!. If the error still comes again then I will try to get the entire fuel system replaced under warranty...
  2. N Kiran

    N Kiran Staff Member Janitor

    Messages:
    1,518
    Hyderabad
    Yesterday I had a similar issue.
    I went out for lunch with couple of my ex-colleuges and it started raining as I was about to leave. It poured heavily and I was enjoying the drive in the rain. At a certain road there was this huge puddle of rain water where I drove pretty fast and I could hear a huge sound of water spraying under the car body. Within few mins, I sensed that there is no turbo boost available anymore and when I try to accelerate the RPM increased without much increase in the speed.
    The "Check engine" warning light was glowing. I thought some thing was wrong with the ECU and kept on driving because I was afriad if I stopped the car it wouldn't start again. I went straight to my relatives where I was supposed to pick-up my wife and daughter. Once I reached the destination, I stopped the car and after few mins tried starting it. The car started, but again with the "Check engine" glow light. I picked my family and drove back home. I was hoping that driving in the water puddle somehow was the culprit. I decided to visit TASS this morning if the glow light comes back.
    When I started the engine this morning there was no error of anykind and my car behaved normal. Guess my Punto also has some kind of a self-recovery system. I had 3 stops and still no error and no difference in the engine behaviour. I am really confused if I need to pay visit to the TASS. To be honest TASS is one thing I am scared about than going to a dentist.

    For now I hope that this error wouldn't come back.
  3. fiat_fan

    fiat_fan Amatore

    Messages:
    185
    Calicut
    @ N Kiran

    I was also caught by the error in a rainy day!!
    did u check in again by accelerating hard at above 2500 RPM at higher gears..??
  4. N Kiran

    N Kiran Staff Member Janitor

    Messages:
    1,518
    Hyderabad
    @fiat_fan: Driving above 2500 RPM is my usual driving style. I have reached almost 4.5k RPM and my car responds as ever. I have reached 100-120 kmph this morning while driving along with a Honda City and Linea. My Punto is absolutely back to life.
  5. VahanPujari

    VahanPujari Staff Member Janitor

    Messages:
    2,303
    Mumbai
    Oh, no. No more common issues please.

    It's such common issues which takes us to TASS every alternate month.
  6. fiat_fan

    fiat_fan Amatore

    Messages:
    185
    Calicut
    oh is this Turbo charger problem common issue??
    btw in my Punto Turbo replacement is worked.. yesterday night we had long trip of 400+ km and did some spirited driving and done maximum of 130km/hr at 2900-300RPM.. now I think my Punto back in action.
  7. amit

    amit Superiore

    Messages:
    767
    Navi Mumbai
    Does the check engine light come on on a rainy day when car is started the first time? My Punto has this issue every rains, it's the second year when this problem has come up. Every time the ASC puts in on the ecu examiner and says there was some error and it's sorted out now. The plus point is that once the car is back from the ASC the problem does not repeat again in the monsoon season.
  8. fiat_fan

    fiat_fan Amatore

    Messages:
    185
    Calicut
    In my case the error comes in between a 400 km trip.. after completing almost 380kms .. It was some leakage issue with turbocharger. That was replaced under warranty..I felt it was too early for my 1.3 MJD which was ran only 23k..
  9. obliex

    obliex Amatore

    Messages:
    146
    Pune
    I had same issue @36000Kms. Check engine light came on with drop in power in 2000-3000rpm band. Lots and lots of black smoke. One of friend even said "Your Linea smokes like and Indica" .Cleaned air filter , did not solve the issue , changed the air filter , did not solve the issue. In the end took it to Pandit Auto . They changed Intercooler to Turbo hose and then the issue was sorted out. Cost of the hose 750Rs.
  10. pemmasg

    pemmasg Regolare

    Messages:
    359
    Chennai
    I am experiencing something similar error now. I got this error[Check Engine] on yesterday[Sunday]. The error stayed permanently for me and my Punto couldn’t cross 110KM/Hr. There was "NO BLACK SMOKE" noticed.

    Today I went to VST Motors Mount Rd Chennai and explained them about the issue. As there is "NO BLACK SMOKE", the technicians decided that it is not a turbo hose issue and they indeed checked it visually too. Then they hooked up the diagnosing tool and cleared the error, unfortunately I was not present at that moment. I asked for the type of the error, they said something like this, "Atmospheric??? Air Circulation??? Insufficient???".

    After clearing the error we went for a test drive, though the "Check Engine" error displayed went away the bad pickup persisted. The test drive driver also felt the same as it is very evident. We came back from test drive and told the SA about the bad pickup in spite of clearing the error. As it was already evening so they said to bring back the vehicle on Thursday[16th Aug].

    I drove back to home slowly as there was heavy down pour in Chennai today evening. The bye-pass at Maduravoyl on my way back to home tempted me to test the MAX Speed. The error came back as soon as I reached 65KM/Hr. I came back home worried.

    Suggestions please!

    Regards
    Gopi

    ---------- Post added August 14, 2012 at 09:56 AM ---------- Previous post was August 13, 2012 at 10:24 PM ----------

    Today I called my SA and told him about fiat_fan's experience about how the turbo charger change fixed the issue.
    But they want to go by their own experimentation with speed sensor checks and some hose fetching air to turbo checks. I thought of giving them a chance to do their experiments and said OK to them. I will update further on this by Thursday evening.

    Regards
    Gopi
    Last edited: Aug 13, 2012

Share This Page