1. Introducing the smashing new Team FIAT T-Shirt !! To order yours click here : Team FIAT T-Shirt

Check engine error

Discussion in 'Punto 1.3 MJD' started by Rajashekhar, Mar 2, 2016.

  1. Rajashekhar

    Rajashekhar Timido

    Messages:
    3
    hubli
    Grande Punto 1.3
    friends.. I am getting check engine error after 32000+ kms. Using punto emotion bought 2 years back. Consulted Fiat team, but want to know anyone is getting same error. This is repetative error coming after crossing 80km/hour.
  2. carl_jhonson

    carl_jhonson Amatore

    Messages:
    98
    Chennai
    Punto Evo 1.3 90 HP
    Rajashekhar and limraj like this.
  3. Rajashekhar

    Rajashekhar Timido

    Messages:
    3
    hubli
    Grande Punto 1.3
    Thanks for the link..exactly same is issue with my car.. unfortunately don't have "experts" to solve...
  4. Deepak

    Deepak Regolare

    Messages:
    459
    KA-30
    Bengaluru
    Punto Evo 1.3 90 HP
    @Rajashekhar: any luck on the issue? Link shared by @carl_Johnson is very informative. You can follow the same for diagnosis.


    Sent from my XT1068 using Tapatalk
  5. Rajashekhar

    Rajashekhar Timido

    Messages:
    3
    hubli
    Grande Punto 1.3
    Discussed with service dealer but error code was not related to above solution.

    Problem found with engine harness and throttle potentiometer. Got both replaced.
    It's running well now. Hope I will be happy in future also.
    Deepak likes this.
  6. mhitesh

    mhitesh Amatore

    Messages:
    158
    Airoli, Navi Mumbai
    Airoli, Navi Mumbai
    Grande Punto 1.4
    I have a Punto 1.4 Emo Pk, It is 5 years old now. For a few months now I have been getting the same error which sometimes stays for a while - couple of hours, seconds or minutes and disappears all of a sudden.
    I have also been facing a mileage issue and the mileage had earlier dropped to 4.5Kms. I reported both these issues at Balaji Fiat a few times however all they used to do was clean the air and oil filter and say that the mileage issue has been resolved, they even tried to find the issue related to the engine check error however they always used to come back saying that nothing was detected.
    For the past couple of months, the issue was intermittent, now after I did my 5th year servicing at Lifetime Mobbilities Thane, the issue started creeping up. I had reported the same to Lifetime, but they were not able to find anything as well. The issue with the mileage started again and I am now getting anywhere between 8 - 8.5Kms. After this servicing with Lifetime, the Check Engine error has become very frequent and sometimes the car has even lost power. The car loses power when the Check Engine Light starts flickering.
    I have some added issues as well after the servicing which lifetime was not able to diagnose, one is with the breaks. It is sometimes that when I break I can hear a sound which feels that the breaks are not oiled or are jammed. This is again intermittent. They have charged me for all the fluids but when I checked the car before taking it to RS Motors there was hardly any coolant.

    I felt it is high time that I should escalate this to Fiat which I did. Fiat has asked me to take the vehicle to R.S Motors, I have now given my Punto at RS on Tuesday. They have found three errors for which I will ask them the details once I collect the car - one is with the carburetor, other with the second cylinder misfiring and I don't remember the third one. I asked them to check all the fluids levels in the car.

    I received a call from RS Motors yesterday saying that they have replaced the ignition coil which was causing the issue and they have been doing test drives to check if the issue comes again. They will call me again to know the final results and I will update accordingly.
    Deepak likes this.
  7. Deepak

    Deepak Regolare

    Messages:
    459
    KA-30
    Bengaluru
    Punto Evo 1.3 90 HP
    i had the same mileage issue in my i10. During a car wash engine bay area was washed with pressurized water. Water got into one of the spark plug and one cylinder was misfiring. Till the spark plug eplaced/cleaned i used to get 8kmpl mileage.
  8. mhitesh

    mhitesh Amatore

    Messages:
    158
    Airoli, Navi Mumbai
    Airoli, Navi Mumbai
    Grande Punto 1.4
    I got my Punto delivered after the issue resolution yesterday evening, till now the issue hasn't crept back and I hope this doesn't creep up again.

    At RS they replaced the ignition coil, after which again they found the issue with the lambda sensor and said they will first clean the sensor and check, thankfully just after cleaning the sensor the issue seems to have resolved. They kept the car for 5 days for a thorough check.

    Really surprised that other centers like Balaji and Lifetime have not been able to diagnose this issue in the past few months.

    I am yet to check whether the mileage issue has resolved. The Trip meter shows 8.6Km/ltr, will wait and watch for improvements. But even when I had manually calculated earlier the mileage has been approximately the same
    Deepak likes this.

Share This Page