1. Introducing the smashing new Team FIAT T-Shirt !! To order yours click here : Team FIAT T-Shirt

Check battery sign appears exactly after 3 mins.

Discussion in 'Engine Compartment' started by sreedhara_bj, Mar 13, 2016.

  1. sreedhara_bj

    sreedhara_bj Amatore

    Messages:
    144
    Bangalore
    Hi experts, need your advice here.

    Following check battery sign appears exactly after 3 mins (yes I measured it 4-5 times) of starting the engine and will remain till engine is switched off (did 1.5 hrs of driving today, it was ON till the end. Almost 100+ kms.) If I crank the car, it will disappear , but will re-appear after 3 mins.

    Battery is relatively new Amaron 48 months warranty ( purchased 1.5 years back, 15k kms done). There is no issue with the voltage readings as well.

    One more issue also I observed off late, whenever I drive over the humps (occasionally I do this, just to check if there is any unwanted sound/rattles) , hand break sign will blink and go. Is it by any chance related to above issue? What could be the reason . If there is some loose contact, then where?

    I'm sure you guys will tell me to go to service centre immediately :D which I'm planing to do very soon. I need expert advice before giving it there. Also I'm not planing for any long trip in-between. Atleast till next weekend, my car will be idle. Do I need to remove +ve terminal? (which I did for following issue, https://www.teamfiat.com/threads/battery-draining-rapidly-ac-not-working.13618/#post-841927872)

    Thanks for the help in advance :)

    Check_battery.jpg
  2. sreedhara_bj

    sreedhara_bj Amatore

    Messages:
    144
    Bangalore
    No reply from anyone even after 2 days :(
  3. varin11

    varin11 Superiore

    Messages:
    821
    Mumbai
    Bombay
    Linea 1.3
    If battery is k... engine cranking well... voltage fine and still problem and this could be problem with alternator or extreme area BCM....might be.
    Get it checked if this not wiring issue or something...get it scanned..what is the error.
    Last edited: Mar 20, 2016
  4. RaviHegde

    RaviHegde Regolare

    Messages:
    299
    Karnataka
    14.62°N 74.85°E
    Grande Punto 1.4
    Prime suspect is battery charging circuit. Car detects battery is not being charged and displays error. If you drive like this your battery is likely to go flat soon!
  5. sreedhara_bj

    sreedhara_bj Amatore

    Messages:
    144
    Bangalore
    I got my car serviced last week. As per SA, it was an earthing issue, battery earthing wire was cut loose. Haven't seen this while driving back home. Need to observe for some more time before confirming.

Share This Page