1. Introducing the smashing new Team FIAT T-Shirt !! To order yours click here : Team FIAT T-Shirt

Car gasping for breath

Discussion in 'Engine Compartment' started by theblack, Jun 16, 2013.

  1. Surya

    Surya Superiore

    Messages:
    930
    Namma Bengaluru
    I think Its recommended as such for long runs tank to tank.
    1 person likes this.
  2. theblack

    theblack Esperto

    Messages:
    2,188
    Bangalore
    its more of how you add the additives than when.
    Ultimately they get mixed with the fuel and do there job so it doesn't matter at all. What needs to be thought of is how much to be added per unit volume of fuel. (which usually is written on the additive anyway!!)

    not necessarily tank to tank . In case of ABRO it was 10% by volume of fuel or full bottle for a full tank.
    I'm not aware of other additives but i'm guessing its mostly the same.
    1 person likes this.
  3. Long run I guess as it will keep the engine running for longer duration hence more time for additives to clean the engine.
    1 person likes this.
  4. theblack

    theblack Esperto

    Messages:
    2,188
    Bangalore
    Ok during my 45K service . I got all the turbo components checked, hoses checked and there was absolutely no problems.
    That very night i took it out for a spin to see how it had turned out and on the highway it again happened.
    I got up to 3000rpm in 5th gear and felt that that car is not responding to my input anymore.
    I held the A pedal for a few secs, may be 10 secs and slowly the car began to come to life and there after it reached >3000rpm .
    This happened twice and thereafter there was no issues.

    I'm currently getting really worried because i looking at 99RPM the cost of the pump is 21K :(
    This does not happen always but it does occur . I might have killed my warranty as well because of all the aftermarket services (i'm not cribbing) but is there any proper way to diagnose this issue?

    I'm hoping to resolve this issue as soon as possible

    - - - Merged Post - - -

    just to remind , i dont have this issue with any other gear. i've tried by taking my car to >3000rpm in 3rd and 4th as well.
    The movement is effortless .Its only in 5th gear
  5. pioneeraaron

    pioneeraaron Superiore

    Messages:
    716
    Mulund/Mumbai
    @theblack

    Get your EGR valve cleaning done once.And Oh-la-la feel the difference :-D
  6. theblack

    theblack Esperto

    Messages:
    2,188
    Bangalore
    pioneeraaron, i got it done a few thousands of kms earlier itself!! :)
    (I was one of the first advocates for EGR cleaning along with Sat) :)
  7. Maddy79

    Maddy79 Amatore

    Messages:
    71
    Hyderabad
    Hyderabad
    Grande Punto 1.3
    Even I feel the same with my GP, same as @theblack is this normal
    My GP is just 16 months old with 15k on ODO, bought this car exclusively for highway drives and serving the same.
    I drive it sedately between 2000-2500rpm, but spike the rpm upto 3000 for some time during each trip for the sake of injectors.
    In recent times I observed that while accelerating in 5th gear, engine response is discrete at few times after ~1800rpm,hope this is where the turbo kicks for 76hp (I mean the pull is not continuous but pauses for a fraction of a second for 3 or 4 instances till 2500rpm).

    I freqently inspect under hood for any abnormal sounds and oil leaks.So far did not find any.The air filter is cleaned every 2000km & engine oil is changed twice till date.
    I always do a tankful on every refill and don't change fuel stations every now and then.
    Added RD box quite from starting (when ~1000 km on ODO) and drove it mostly in P1 mode only.Since after observing this event, changed it to stock mode ,but observed the same discreteness.

    Just added ABRO to tank full early in the morning and took it for a spin,did a sprint drive for 25kms and couldn't make any difference.
    Guess this is too early to conclude on ABRO to work, But kindly share your thoughts on such engine response.
    Little sceptical in visiting FACC guys as they wouldn't agree/observe this scenario in first place and simply say "all such things are normal" and its just my hallucination :banghead:

    @theblack
    I know it's quite long for this ask but were you able to figure out / fix this issue with your car.
    Last edited: Oct 3, 2015

Share This Page