1. Introducing the smashing new Team FIAT T-Shirt !! To order yours click here : Team FIAT T-Shirt

Car and Lock sign on the dash

Discussion in 'Electrical Systems' started by niyaz, Jul 16, 2012.

  1. niyaz

    niyaz

    Messages:
    2
    Hi there. I own a Punto 1.3 MJD and have completed 42000 Kms since Nov 10, 2009. Never changed my battery since then. Never had any starting problems. Rarely used head lamps because I don't drive in night. Late last month, I drove the car till the last drop of diesel and the car did not start (so stupid of mine). I was under the impression that there is some diesel still left and I was waiting for the first of July to fill my tank (easy to keep account). I called my Fiat service adviser Mr Hitesh Patel (Malik Cars, Hyderabad) and he said nothing to worry, just fill diesel and start normally. I did the same and the car started. However, I noticed that the amber colored sign (car and lock) flashed on the dash for a while during driving.
    I drove few kilometers, filled half tank and parked the car at home normally and went away for a week. After my return, I found the car non responsive to repeated selfs and did not start. I called FIAT helpline and a local mechanic rushed to my apartment with a battery and jump started. I narrated him my background problem and he drained some diesel from the fuel filter suspecting an airlock. The car cranked normally and is running fine for 3 weeks since then. Today again I noticed the same sign on my dash as it did not disppear after starting. I drove for 5 kilometers with that, came home, switched off and again switched on the car. Drove it for a while and this time the sign disappeared soon after cranking and then did not appear again. My fuel level is on the last quarter but did not reach reserve. Now, my worry is, is it due to a weak battery? Is it a self test of low voltage? or is that the Fiat system code failure? The sign is coming with both the keys. I alternate my keys every year or in 6 months. Did any one notice this thing. Please help me.
  2. sungoa2010

    sungoa2010

    Messages:
    2,878
    Goa
    Do you check the battery in regular interval? For 2009 model the battery is old now. Check the battery at a battery shop also the electrolyte level.
  3. Cashier

    Cashier Amatore

    Messages:
    89
    Mumbai
    If the Sign disappears after cranking the car, I am inclined to think the battery might be the problem, have it checked as Sun advised, I had a similar problem and the battery seemed to be the culprit.
  4. karan desai

    karan desai Superiore

    Messages:
    805
    Morbi, Gujrat
    me too had the same problem culprit was weak battery. get it charged at a shop
  5. niyaz

    niyaz

    Messages:
    2
    The battery was indeed the culprit. Today it fell dead and did not help in any case. I had to run one shop to the other. The stock battery was 12V50AH Exide on my MJD. It was out of stock and they suggested Amaron model Flo AAM-FL-555112054 (95Min/540Amp). They told me this is 55AH but I have no means to determine the AH rating from these statistics. Amaron website is silent on this model. The make date is 06/2012. I got it for 5000 INR with 48 months warranty, zero maintenance. The bracket under the hood was just sufficient to accommodate the battery. The MJD beast woke up and roared immediately in one crank and all lights were quite bright. I am happy, but perplexed on getting lost in to the business of AH rating and I must also know if my alternator would be able to charge this type of battery. Friends please help me decoding this magic number from Amaron and advise.
  6. Nikhil Goel

    Nikhil Goel Amatore

    me too got the same problem replaced the battery problem solved.
    my punto emotion diesel done 46000Kms. 2.25 yrs old.
  7. Ravi

    Ravi Staff Member Janitor

    Messages:
    6,001
    Bangalore
    Grande Punto 1.3
    First 3 letter tells about details, 1st tells about model, and next 2 tells DIN, so its DIN55.

    How I know, because I also got same model and verified with Amaron dealer.
  8. Naughty

    Naughty Superiore

    Messages:
    600
    Ahmedabad
    My FGP is also November 2009 model... Though It has run for only 27000-28000 Km.

    Last month I too faced the same problem... Battery was the culprit...
    Amaron Dealers quoted me Rs.6250 for DIN50 after deduction of the old battery dont remember the model number now...
    Exide guy quoted me Rs.4800 for DIN55 after deduction of the old battery....

    Installed Exide DIN55... No probs anymore... :up
  9. clash81

    clash81 Regolare

    Messages:
    398
    Bangalore
    Facing this issue + Air Bag failure that appears on and off. Should check the battery! :(
  10. amar_gahir

    amar_gahir Amatore

    Messages:
    76
    Delhi
    Yes. check the battery ;

    1. Fluids
    2. Voltage when engine is off
    3. Voltage when staring the engine.

    Problem is generally seen in point 3....where battery is not able to provide enough voltage for vehicle to start properly....

Share This Page