1. Introducing the smashing new Team FIAT T-Shirt !! To order yours click here : Team FIAT T-Shirt

Canbus LED - What went wrong??

Discussion in 'Electrical Systems' started by chethansgangoor, Aug 8, 2013.

  1. I had ordered W5W canbus LEDs from ebay.

    2X OBC Error Free Canbus T10 4 SMD 1 5W High Power LED W5W Wedge Car Bulbs 12V | eBay

    Received them yesterday and was very excited to use them as parking bulbs inside the headlamp. Yesterday night replaced the stock W5W bulbs with this. Turned on the lights, there were no errors in the MID. All happy with the setup, decided to go out on a drive at 8 PM. My excitement was short lived, after 5 or 10 mins of driving, noticed the bulb blown indicator on MID. Stopped the car to check whether one of the bulb is not connected properly.

    I was shocked! there was no bulb at all, both the bulbs were melted and just the wedge were left
    Could you please help me to understand what went wrong here??

    I have another four bulbs of this type:
    4X Canbus Error Free T10 194 W5W Turn Tail LED 9 5050 SMD BMW Benz W204 White | eBay

    And i am just scared to attempt an install till i have the understanding of compatible bulbs.
  2. kirenh

    kirenh Regolare

    Messages:
    421
    Mumbai/Pune
    Pune
    Grande Punto 1.3 90 HP
    Chetan,

    Whats your HL setup and the temperature inside the HL assembly? Do you use 100/90?

    Kiran
  3. I am using 55-60 Philips Extreme Vision and the headlight is stock.
  4. theblack

    theblack Esperto

    Messages:
    2,188
    Bangalore
    i'm not an expert in electricals in any which way but did you try and see what is the current load that LED can handle?
    If it's beyond what it can handle then something like this will happen!
    Apart from this i dont see any problems with wiring or anything like that.
    55/60 EW bulbs are perfectly OK. I've used LED parking lights in combination with my 110/130 bulbs a few years back and i didn't have any burn out issues.
  5. PatchyBoy

    PatchyBoy Esperto

    Messages:
    2,438
    Bangalore
    There is nothing wrong. Those LEDs are not designed to take the heat of the headlamp. In the punto, since the parking light and the headlamp are in the same enclosure, these LEDs are not suitable for use. You can use them everywhere else in the car - side repeaters, tail lights, number plate lights, etc.

    Our fellow TFIan, Thomman has already tried this with the same results. Please search his thread.

    Rajan

    PS: Found it. Here is the link
    Last edited: Aug 8, 2013
    4 people like this.
  6. Last edited: Aug 8, 2013
    1 person likes this.

Share This Page