1. Introducing the smashing new Team FIAT T-Shirt !! To order yours click here : Team FIAT T-Shirt

Boot lamp issue in Fiat Linea

Discussion in 'Electrical Systems' started by Aashish Kulkarni, Apr 1, 2015.

  1. Aashish Kulkarni

    Aashish Kulkarni Timido

    Messages:
    13
    Pune
    Pune
    Fiat Enthusiast
    I have recently purchased Fiat Linea Emotion. All electrical system is working fine except boot lamp. At the time of purchase, Number Plate Lamp was not working and there was a message on MID to that effect. Replaced T10/ 5W5 bulb and that message went away. I also saw that there is a Boot Lamp in the boot but it's not functional. I did some diagnostics and here is my observation:
    1. BCM is able to sense boot open and close correctly and no issues on that front.
    2. There is no message on MID about Boot Lamp failure.
    3. When the boot is open, I can see that there is +12V present and 0V when boot door is closed.
    4. The boot lamp is not fused and I verified it. The contacts at the holder are also fine and here it gets more interesting, as 12V is correctly present, I tried to measure that current and I can see that the circuit is supplying on 20mA current and not more than that. It means, 1/4th of Watt in comparison with 5W that is required.

    Has anyone faced this issue earlier. Is this issue a BCM fault?

    Regards,
    Aashish
  2. Maddy79

    Maddy79 Amatore

    Messages:
    71
    Hyderabad
    Hyderabad
    Grande Punto 1.3
    Boot lamp switch is an integral part of boot/trunk latch mechanism. Hope that 20mA is the leakage current of entire vehicle circuit.
    Kindly check the latch internals for loose contacts or soldered wires. As BCM is able to read trunk open/close, latch switch could be the culprit.Also check the bulb for continuity.Hope you are using a multimeter.
  3. Aashish Kulkarni

    Aashish Kulkarni Timido

    Messages:
    13
    Pune
    Pune
    Fiat Enthusiast
    Yes, I am using multi meter. The bulb is OK. The on voltage is 12.x V and 20ma. Off voltage is 0v and 0ma. So I don't think 20mA is leakage current as such. I feel BCM is faulty as it's not able to switch the earth. Do we have any reference diagram of the electrical system of the car?
  4. Aashish Kulkarni

    Aashish Kulkarni Timido

    Messages:
    13
    Pune
    Pune
    Fiat Enthusiast
    The issue is now resolved. It was a problem with the switch integrated with the boot latch. The contact for the boot door bulb was not getting correctly activated. I applied liberal amount of WD-40 and it started working again. However, in the process, I broke the locking mechanism of the boot lamp and hence it is now stuck using feviquick. But in all, it works fine now.
    --- Double Post Merged, Apr 20, 2015 ---
    Here is an image to explain where the switch is located.

    IMG_20150420_143021.jpg
    pabhishek likes this.

Share This Page