1. Introducing the smashing new Team FIAT T-Shirt !! To order yours click here : Team FIAT T-Shirt

Blue&me Stopped working..

Discussion in 'Blue and Me' started by Flemenco-Red, Feb 24, 2014.

  1. Hello guys...

    I own Fiat Linea MJD Emothion Pack 2011 model. Blue&me stopped working all of a sudden few days ago. Has anyone faced the same problem and could you suggest the next steps pls.

    PS: Have already spoken to Fiat guys and they say it needs to be replaced and would cost around 35K. Hopeless
    :evil::evil::evil:!!!!!

    Thanks & Regards
    Flemenco
  2. Ravi

    Ravi Staff Member Janitor

    Messages:
    6,001
    Bangalore
    Grande Punto 1.3
    Did they give any reason why it stopped working? Can extended warranty cover this?
  3. hello2anand

    hello2anand Amatore

    Messages:
    68
    Bangalore
    35K looks too high....:shocked

    Did you try remove the battery & replace it again ? I have heard in other forums that this normally solves the problem...Or try charging your battery & fit in.

    I own the same variant but in Punto...Mine stopped working few months back....Check with the service guy & said it will not be covered under warranty & it will cost Rs 12K...With nothing else to loose, I raised a complaint to FIAT India CRM. Got a call back saying that it will not be covered as part of warranty as the car was more than two years old.

    So, go ahead & give a try by calling FIAT India CRM...
  4. punto_emotion

    punto_emotion Esperto

    Messages:
    1,245
    Bangalore
    Grande Punto 1.3
    Paying 35k for blue & me! :shocked. One can get a good after market ICE set up for the same amount with leaps and bounds improvement in audio quality. Only flip side would be nonfunctional steering buttons.

    Sent from my Nexus 7 using Tapatalk
  5. vj_v1

    vj_v1 Superiore

    Messages:
    933
    Hyderabad
    The steering controls can very much be retained by installing a Connects 2 Steering adapter.
  6. punto_emotion

    punto_emotion Esperto

    Messages:
    1,245
    Bangalore
    Grande Punto 1.3
    ^^ Have read about the connectors. Are they available easily? Are local after market folks capable of installing the same?

    Sent from my Nexus 7 using Tapatalk
  7. hello2anand

    hello2anand Amatore

    Messages:
    68
    Bangalore
    Yes..they are...When I upgraded my HU, the installer was ready to get one, but I declined as I had to spend more on dampening & amplifier.
    1 person likes this.
  8. Anup

    Anup Regolare

    Messages:
    303
    Bangalore
    Bangalore
    Grande Punto 1.3

    I strongly suggest against you removing B&me box completely, rather do the below DYI:
    > Remove the connection of B&me (After disconnecting the Battery) and spray a little quantity of WD-40 and use a soft tissue/White waste cloth and gently clean the connectors, allow the WD40 to dry completely by keeping it outside for some time and re connect.
    > Or try to download your current version of B&me from the website and try re installing.
  9. vj_v1

    vj_v1 Superiore

    Messages:
    933
    Hyderabad
    1 person likes this.
  10. hello2anand

    hello2anand Amatore

    Messages:
    68
    Bangalore
    Anup, Can you provide a pic of where exactly B&M can be found after removing the battery ?

Share This Page