1. Introducing the smashing new Team FIAT T-Shirt !! To order yours click here : Team FIAT T-Shirt

Blue & Me not working (odo blinking) - How to clean the Unit to make it work

Discussion in 'Do It Yourself' started by hello2anand, Feb 28, 2014.

  1. hello2anand

    hello2anand Amatore

    Messages:
    68
    Bangalore
    TFIATians, Though we have seen multiple threads on issues related 'Blue & Me Not working', I just followed this specific step & to my surprise, B&M started to work after this. :dancing

    Problems :
    1) Blue&Me stopped working. Only the radio & CD works.
    2) Odometer started to blink
    3) USB Port stopped working

    When reported to SA, I was told the B&M Unit needs to replaced worth Rs 12K :firey And all the more, this unit is out of warranty as the car was more than 3 years old.

    Options I tried before cleaning the B&M Unit:
    1) Disconnected the Battery terminals & connected again
    2) Recharged the Battery
    3) Replaced the OEM battery with Amaron. This was required as my OEM was frequently draining out


    Cleaning B&M Unit:
    Here are the steps I followed

    1) Open the glove box
    2) Remove the B&M Holder. Remove the two screws by using allen keys
    BM Holder.jpg


    3) Take out the B&M Unit by removing the connection plug
    BM 1.jpg


    4) Open up the B&M Unit by removing these four screws
    BM 2.jpg

    5) Take out the PCB. I used the 'blower' section of my vacuum cleaner & cleaned both the surface of the PCB. Fortunately I noticed one of the processor unit was very dusty & I cleaned it up with a damp cloth. Note, I didn;t had an all purpose cleaner and hence went with a damp cloth
    PCB.jpg

    6) Assemble everything back
    7) Started the ignition....Hurray !!!!!...:up. Odometer stopped blinking, The USB Port was glowing (which wasn;t before the fix) & Was able to sync my Phone

    Now, here comes the flip side of the story.......Though I fixed the B&M problem, I can't make use of it.....:A I recently replaced the OEM HU last month & added an amp as well....

    Sometimes, we end up learning the hardest way possible...

    Sharing this info to all TFIATians to try all possible options before taking a leap....
    linea4me, ravikn, PradeepM and 22 others like this.
  2. asimpleson

    asimpleson Esperto

    Messages:
    3,000
    Heptanesia
    Linea 1.3
    It's well worth the effort. Kudos to you for making a desperate yet bold move. :clap:up
    It is indeed heart rending to see electronics fail leaving one with no option but to replace parts; you have indeed proved otherwise. ::D
    prabhjot and hello2anand like this.
  3. zenwalker

    zenwalker Esperto

    Messages:
    2,150
    Bangalore
    Nice work there buddy
    So that means, you had this issue even before doing this DYI and now you can use your BnM only for making calls right?
  4. hello2anand

    hello2anand Amatore

    Messages:
    68
    Bangalore
    Thanks asimpleson....What concerns me was the SA with whom I raised the problem, confirmed the Unit was spolied by Rodent entry and has to be replaced. But my physical examination revealed the true story....Now that really questions their integrity & Customer satisfaction...:thumbs down
    prabhjot likes this.
  5. pabhishek

    pabhishek Esperto

    Messages:
    1,381
    Oslo
    Pune
    Linea T-Jet
    Its a simple yet great stuff!! Kudos to you.
    Everyone should vouch for cleaning of B&M unit before replacing it.
  6. asimpleson

    asimpleson Esperto

    Messages:
    3,000
    Heptanesia
    Linea 1.3
    I hope Fiat reads this. Maybe the SA was simply ignorant or innocent, but was this callousness, it surely was. I don't know surely if you should post these incidents to Fiat Customers service for various reasons, one of which is to keep them informed of Blue and Me troubles. I wish they had an RTI thing for car manufacturers as well. :evilsmile
  7. hello2anand

    hello2anand Amatore

    Messages:
    68
    Bangalore
    Yes..I had the problem for sometime...then decided to get rid of OEM HU for this sole reason & replaced with an aftermarket one last month. I replaced it a week after the SA told me about his so called myth on the B&M Unit :punch)...

    Coming to your Q, it s a big & a sad NO...I'll not be able to use the OEM B&M feature due to change in HU wiring setup...However, there are two takeaways...

    1) As I said earlier, we need to be sure of the problem before replacing - especially on the B&M Unit - A big lesson learned
    2) My Odometer no longer blinks :clapping
  8. ghodlur

    ghodlur Esperto

    Messages:
    2,319
    Thane
    That's a brave effort to prove the Fiat SA wrong. Sad to know that its not working for you. Nevertheless superlative effort, atleast TFIians know where to check first before they meet the SA.

    Reg the damp cloth, I wouldn't advise that. Instead a good electrical contact cleaner would be a better option. Dampness left on the electronic components tend to be far more damaging than the dust accumulated.
    prabhjot and hello2anand like this.
  9. PaddleShifter

    PaddleShifter Staff Member Janitor

    Messages:
    2,697
    Chandigarh
    Grande Punto 1.3
    I would like to add one more point to what ghodlur has suggested above.

    It is generally a good idea to touch a metal surface or touch the feet to the ground to let go of the static charge on the body. Its a very commonly seen precaution that most of us must have already come across but still thought I should write it here.
  10. asimpleson

    asimpleson Esperto

    Messages:
    3,000
    Heptanesia
    Linea 1.3
    Two very good and valid tips. As regards, ghodlur's point, normally you get an IPA bottle that is commonly used from electronics shop, mostly used also while cleaning solder contacts on PCBs.

Share This Page