1. Introducing the smashing new Team FIAT T-Shirt !! To order yours click here : Team FIAT T-Shirt

Blinking ODO Meter Reading

Discussion in 'Electrical Systems' started by anand3636, Apr 19, 2012.

  1. theblack

    theblack Esperto

    Messages:
    2,188
    Bangalore
    hmm.. so the elusive ODO blink continues..
    I'm really interested in knowing the reason , i guess we should file for information with the FIAT guys (not our dealers ) and see what they have to say..
    So many folks and still no answer.. it getting better and better by the day :)
  2. oasis.07

    oasis.07

    Messages:
    3
    Noida
    Nothing related to low tyre pressure or puncture....I would suggest to disconnect the battery by removing the connection on -ve terminal, wait for a minute and reconnect it. It should solve the problem as I resolved this issue in the same way with my GP90hp.
  3. I had a blinking ODO because of dead Blue & ME unit. Whenever the ECU returns an error code there is blinking ODO. In my case the battery method did not work and when the TASS guy put a scanner we got BLUE & ME error. Once the Blue & Me unit was replaced the error went out.
  4. winimation

    winimation Amatore

    Messages:
    100
    Mumbai
    The problem of blinking odo is quite often because of problems with Blue & Me. I had a similar problem with GP & the guy did some wiring check near the blue & me area & the problem was gone.

    Also while updating Blue & me from 5.4 to 5.5, I was not sure whether the update is running as sometimes it doesn't give any indicator. I pulled out the pendrive midway & I started getting the blinking odo error. I again switched off the engine & repeated the same operation witht he pendrive. Blue & me got updated to 5.5 & the blinking problem was gone.
  5. iamsameerj

    iamsameerj

    Messages:
    6
    Pune
    Since today morning, I am also experiencing this issue, however, in my case, it is the current time that is blinking. Just yesterday, I had picked up the car (Punto Emotion 76 BHP) from the TASS and dont think it was blinking then, or if it was, did not notice it. The blinking did not go away even with a restart (hot start). Just couple of days back, I had experienced a diesel leak from the diesel filter and as advised by the SA, had removed the battery -ve terminal and the problem apparently seems to have started after that:sad:
    Seems like all possible solutions/suggestions mentioned in this thread will not work in my case. Will check again later today and if the time is still blinking, will call the TASS for a solution. Will post updates on this soon...
  6. ops

    ops Amatore

    Messages:
    55
    Kathmandu
    Nepal
    Punto Abarth
    i also faced blinking odo couple of times in my linea 2011 mjd . It disappeared after re-starting engine. Don't know the cause.
    Last edited: Jul 18, 2012
  7. Relativity

    Relativity Superiore

    Messages:
    853
    Chennai
    It hapenned after I had reset the ECU but it went away on its own.
  8. carwatcher

    carwatcher

    Messages:
    39
    Goa
    Yesterday I had the ODO KM reading blinking in my T-Jet. I pressed the call button on my steering and it disappeared. Then within 5 mins, it started blinking again and I repeated the procedure. Then it again happened for third time and after I repeated the procedure it disappeared again and didn't come back till date. This has happened 2-3 months ago once and I switched off the engine and switched back on, it didn't come till yesterday. Is it due to battery current levels or Blue n Me we don't know.
  9. theblack

    theblack Esperto

    Messages:
    2,188
    Bangalore
    So many posts and still no idea about this issue
    I think we should contact one of the fiat top brass and try to figure this out
    :)
  10. sungoa2010

    sungoa2010

    Messages:
    2,878
    Goa
    Is it something to with moisture? Looks like when monsoon started many are getting the same problem.

Share This Page