1. Introducing the smashing new Team FIAT T-Shirt !! To order yours click here : Team FIAT T-Shirt

Blinking ODO Meter Reading

Discussion in 'Electrical Systems' started by anand3636, Apr 19, 2012.

  1. theblack

    theblack Esperto

    Messages:
    2,188
    Bangalore
    i dont know if it mean a tire puncture because thus far I've had nearly 4 punctures on 2 tires and I've never noticed the MID blinking.
    It just happened once and they vanished never to reappear (at least not till now :) )
  2. prashantgupta84

    prashantgupta84 Regolare

    Messages:
    383
    New Delhi
    Delhi
    Grande Punto 1.3
    maybe it was indicating to me of less air in the left tyre...anyways there are so many small small feature.....even Fiat may not be knowing and definitely not the SA...:)
  3. anand3636

    anand3636 Amatore

    Messages:
    51
    Cochin (KL - 44)
    it was not there this morning. thank god. may be the car demands some more attention from me!!!!!! something like " me or wife"?
  4. Please ask your service center to carry out a proxy alignment procedure. if it still persists it means the Blue&Me just went kaput. U'll need a replacement for the module.
  5. I had faced similar condition few times. I had stopped automatically or after stopping and starting the car. Does this condition suggest any issue? My B&M works fine.
  6. I too had this issue two days back. But the fact then was my Phone's Bluetooth was turned off accidentally. I was wondering whether the MID blinking was to convey that device pairing had failed . Once i did the routine of turning the engine off and on it went.
  7. fiatlover

    fiatlover Esperto

    Messages:
    1,599
    Bangalore/Kasargod
    Bangalore
    Grande Punto 1.4
    No, I dont think this has anything to do with any niggle or issues with tyre.
    May be this has something to do with the battery. A dying battery perhaps. How old is your car?
    I got a bunch of such errors recently, such as odo blinking, lock sign glowing, ABS failure, EBD failure etc. The car was also having starting problem. The TASS diagnosed it as hot-start problem. That is, car starts without issues in when engine is cold, but is difficult to start when hot, say after running some 10-15 kms. The battery was unable to take the load when hot. I finally had to replace the battery (EXIDE 2year & 9months old) and all these issues vanished. Two weeks now, none of the above issues appeared again.

    Aside: When you get any of the above mentioned errors, just restart the car, the error vanishes. (typical microsoft method of troubleshooting: When nothing works, restart!)
  8. mvb4u

    mvb4u Regolare

    Messages:
    384
    AndhraPradesh
    Guntur
    Grande Punto 1.3
    Just one doubt here, may be out of thread, which mode of starting (cold start - i.e engine is at room temperature or hot start - i.e the engine has run for some time and attained operating temperature and stopped and now we want to start it again) draws more power from the battery? to put it differently for a dying battery is it difficult to start a cold engine or a hot engine?
  9. DRIV3R

    DRIV3R Esperto

    Blinking ODO is sign of a weak battery. Give her a good run and it should disappear. Generally happens in the first early morning start.
  10. ops

    ops Amatore

    Messages:
    55
    Kathmandu
    Nepal
    Punto Abarth
    I too noticed odo of my linea blinking couple of days back. Odo reading was 3200 only. After restarting engine the issue disappeared on its own.

Share This Page