1. Introducing the smashing new Team FIAT T-Shirt !! To order yours click here : Team FIAT T-Shirt

BLAUPUNKT THA555PNP Car Amplifier

Discussion in 'In Car Entertainment' started by Viny, Jan 3, 2011.

  1. Viny

    Viny Esperto

    Messages:
    1,742
    :)
    Congrats :)
    And what do you expect the ICE shop guy to say :p
    Black wire is for BASS Control, 4 screws are for mounting your amp and there must be a black bass controller and 2pcs of 40 AMP fuse too
  2. Ravi

    Ravi Staff Member Janitor

    Messages:
    6,001
    Bangalore
    Grande Punto 1.3
    If he has installed this amp before or not ::D .
    These things are there, but only one fuse. Hope not big issue.
  3. Viny

    Viny Esperto

    Messages:
    1,742
    :)
    Ravi: Installation of AMP is very simple, you can go through the DIY amp installation steps that I have given, this will help you in better understanding of the entire process. DIY - Installations Steps viewtopic.php?f=13&t=1476&start=200#p31811

    I guess the second fuse is already placed in AMP then. Anyway you can get those fuse very easily if and when required.
  4. Ravi

    Ravi Staff Member Janitor

    Messages:
    6,001
    Bangalore
    Grande Punto 1.3
    Viny, i read the post about DIY, but i don't have skill to do that.

    Also, currently i don't have extension cable, so i need to enquire about that also, if the installer can do something about that.
  5. Viny

    Viny Esperto

    Messages:
    1,742
    :)
    If you dont have extension cable then also no problem, you can use it as normal ampli, any installer can do the installation as normal ampli, have to pull wires from HU to AMP and from AMP to speakers. AMP comes with default connector heads for same. If you have to use PNP extension, then one needs to pull out these heads :D
  6. Viny

    Viny Esperto

    Messages:
    1,742
    :)
  7. mindgrinder

    mindgrinder Novizio

    Messages:
    38
    Delhi
    problem with blaupunkt 55 PnP amp

    i have got this strange problem with 555 pnp if anyone could help. Sometimes when i play loud music. The amp goes "pat pat" sound kinda like its broken. Songs call everything break up, just like bad static on a phone. If i switch off the car and let amp to cool, the sound goes away. I am wondering if the sound is from blue and me, or the amp. Harness kit and wiring are new....

    Any suggestions?
  8. Dilip_dmk

    Dilip_dmk Superiore

    Messages:
    649
    Delhi, India
    New Delhi
    Grande Punto 1.2
  9. Viny

    Viny Esperto

    Messages:
    1,742
    :)
    Re: problem with blaupunkt 55 PnP amp

    @mindgrinder: Kindly share your installation pics and amp control panel pics. Also would like to know how you have powered your amp.
    Do check out your earthing connection.
  10. Ravi

    Ravi Staff Member Janitor

    Messages:
    6,001
    Bangalore
    Grande Punto 1.3
    Mods Note - Thread Merged.

Share This Page