1. Introducing the smashing new Team FIAT T-Shirt !! To order yours click here : Team FIAT T-Shirt

Battery light off then goes on after sometime!!

Discussion in 'Electrical Systems' started by vivek_lko, Oct 26, 2014.

  1. vivek_lko

    vivek_lko Amatore

    Hi Guys ,
    Car 90hp 2010 model run 56K kms . Latest 5th service done last week from Kashyap Fiat .

    I had come to lucknow from Noida for Diwali vacations. I had to go back tomorrow but today I noticed that the battery warning light which should go off and remain off once the engine is running, does go off after starting the engine ; only to become on after some time . Once on, it remains so even if the car becomes stationary while the engine is still running . My battery is new and I replaced it in June.

    I tried doing the following
    1. When the battery light is on and engine is still running I disconnect the battery terminals and I notice that the engine is switched off . Does it indicate that there is some issue in the alternator ?

    Also any one knows some alternative workshop in lucknow other than Classic . I will show the car to Classic tommorow but after talking to them they told me that in case the alternator requires a change they still dont have the alternator available .
    Still pathetic state of affairs in Fiat service though !!
    Last edited: Oct 26, 2014
  2. vivek_lko

    vivek_lko Amatore

    guys can anyone give me the number of mangesh..just in case I need it due to some issue in getting the car fixed.
  3. ghodlur

    ghodlur Esperto

    First things first. Never even attempt this action again. Esp when the engine is running. Yes the battery indication on the MID should be off when the engine is running but if it is ON, then there must be an issue. Suggest to show it to the Fiat workshop since you say the battery is new. Maybe the ECU isnt reading the battery voltages.

    BTW have you installed the correct specification battery?
    mchanna likes this.
  4. mchanna

    mchanna Superiore

    Its the alternator issue if the battery symbol light is still on. Fix an appointment with the FASS. They will be able to fix it.
    BTW have you by any chance driven on water filled roads?
  5. vivek_lko

    vivek_lko Amatore

    @mchana am at classic fiat Lucknow. They checked the stuff and have confirmed that alternator is gone. They don't have a spare one with them. Since I have to leave for Delhi tomorrow they are trying to arrange one from a demo car. Regarding the battery it
    is 55ah amron battery which I replaced in June this year.
    --- Double Post Merged, Oct 27, 2014 ---
    btw please let me know why you are saying its not correct to test the alternator by using the "battery removal while the engine is running method ". The car is stationary though.
  6. swgaan

    swgaan Amatore

    Panvel, Maharashtra
    Grande Punto 1.3
    The Same thing happened with me yesterday, i was on my way to inlaws, in the mid i stopped for Refueling, as a general practice, i switched off the car and took out the keys, after Refueling, when i turned the Key MAR, there's a warning light comes on as attached in below pic. but after doing doing it again (i.e. switch off and on) it went away, I guess i need to replace the battery, also the crank time have also increased since month before i've noticed that, but i didn't realized that it might be because of the battery.

    DEEPAK BAPAT likes this.
  7. Punto Maniac

    Punto Maniac Amatore

    Are you saying that you did all the 74K Km on the stock battery? How old is your battery/car? Do you know if the battery was changed ever for the car?

Share This Page