1. Introducing the smashing new Team FIAT T-Shirt !! To order yours click here : Team FIAT T-Shirt

Android Apps for FIAT Cars

Discussion in 'Technical' started by Viny, Jun 16, 2014.

  1. MakeTheMove

    MakeTheMove Regolare

    Messages:
    343
    Pune
    Linea T-Jet
    I tried connecting this application with Sept 2013 manufactured T-Jet. I got either Time out error or Bluetooth off message despite bluetooth was on.
    I paired the OBD II bluetooth with android device before opening Lancia Can Bus application.

    I am able to connect to my car with other applications viz. Torque, AlfaOBD. Am I missing anything here? Or this application does not work with recent manufactured cars, which seems to be unlikely case.

    Experts your opinion please.
    Last edited: Jun 25, 2014
  2. sathishgv

    sathishgv Regolare

    Messages:
    496
    Paradip, odisha
    Grande Punto 1.3 90 HP
    Well well well................ nice discussion going on and i missed it so far. Interesting viny and thank you very much for this thread. I pity myself, when i bought ELM327 i went for the cable one without bluetooth :uh. Is there any way i can connect?????

    @vj_v1 out of curiosity, is your problem related to the resistor in the ELM327?
    Last edited: Jun 25, 2014
  3. Viny

    Viny Esperto

    Messages:
    1,742
    :)
    Visit some local seller and test the ELM327 before buying, most of the ELM327 come from same chinese graveyard and there functional behavior fully represents Chinese products characteristics.

    Well we are at very stage of testing the app, so cannot say much if its because new version of tJet. Patchyboy has already got it working on his tJet.
    Can you try it again, this time ensuring that no other app is using connection to ELM.

    We will soon have Fiat Linea specific version too. Work is in progress, so keep a watch on this thread.

    - - - Merged Post - - -

    Sathisgv: Most probably no, given that usb cable will not connect with most of the android devices. Secondly I think this app specifically expects bluetooth connection based ELM327
    2 people like this.
  4. Italia-Linea

    Italia-Linea Staff Member Janitor

    Messages:
    2,123
    Pune
    The key is finding the correct clone. Earlier lots never had a problem of connecting to canbus. These new lots have lots of problem connecting to the various modules. Not only the bluetooth but also the usb ones have problems. Fortunately i had a lot of earlier versions which though costly connect flawlessly to all modules.
  5. vj_v1

    vj_v1 Superiore

    Messages:
    933
    Hyderabad
    Doesn't look like the resistor issue Satish. Since it works it works with other apps.

    Sent from my Moto X using Tapatalk.
  6. MakeTheMove

    MakeTheMove Regolare

    Messages:
    343
    Pune
    Linea T-Jet
    Thanks Viny! I tried this with multiple options
    1. Unpair Blue and me
    2. Different handsets
    3. Handset which do not have any application which uses ELM, except Lancia Can Bus.

    Anyways, I will check once again, otherwise I will check with Italia_Linea. For him it is working with Linea MJD.

    Also, as we are in development phase, It would be nice to consider this point as well so that application would be able to connect with all batches Linea and Punto.

    I will update the thread as soon as I perform test.
    Last edited: Jun 25, 2014
  7. asimpleson

    asimpleson Esperto

    Messages:
    2,998
    Heptanesia
    Linea 1.3
    @vj_v1, It's the case of bluetooth serial service issue. This is not a problem with being cheap chinese clone. If it works with others it should work here as well. The problem happens with certain phones and there could be something the developer of Torque might be working to resolve this.

    If you can use an app called as Bluetooth Auto-Pair, chances are the app might also work. No guarantee about it but poeple have had success with this I read.

    Try these links.. install aptiode first here >> Aptoide Installer

    and then try this >> Bluetooth Auto-Pair | Android Apps (Free APK)
  8. Viny

    Viny Esperto

    Messages:
    1,742
    :)
  9. sathishgv

    sathishgv Regolare

    Messages:
    496
    Paradip, odisha
    Grande Punto 1.3 90 HP
    ^^Yeah already installed and it shows the car model to select as Fiat linea 2007 but i don't have ELM327 that connects with Bluetooth.:(
    Last edited: Jun 27, 2014
  10. asimpleson

    asimpleson Esperto

    Messages:
    2,998
    Heptanesia
    Linea 1.3
    On the question asked previously about which ELM327 based adapter to buy, one should ideally get the original microchip technology based product. While vendors or manufacturers are largely based in China (also making chinese clones), the difference is in cheap and expensive implementations. If one can afford he should go for the expensive models from abroad (with replacement or tech support), but the cheaper ones could work as good and are tempting to buy for some non-professional use.

    There is one Vgate brand available in market which looks good from reviews. The software (firmware) version should be 1.5 or 1.5a to support latest command set. Else certain advanced features will be missing or deactivated.

    Last edited: Jun 27, 2014
    1 person likes this.

Share This Page