1. Introducing the smashing new Team FIAT T-Shirt !! To order yours click here : Team FIAT T-Shirt

Air filter cover

Discussion in 'Engine Compartment' started by drgopusankar, Nov 6, 2011.

  1. Hello friends,

    2 days back when i cleaned the air filter and put it back, i noticed that the left screw of the cover :( was not tightening to its full end. The middle and right ones are ok. Is there any problem? How can i rectify it?::pp
  2. Tron

    Tron Superiore

    dude dont panic! Its very common problem. Its just because initial alignment of your screws is little off-set. Remove all of em & place em again. While screwing down those take care that hole of your airfilter's cover is properly align. Also make sure that your screws are exactly in 90 degree while you are screwing them down!
    Last edited: Nov 6, 2011
  3. As tron told.. remove all the screws and then put the cover again and then fix the left and right screws and when it is little tight, put the middle screw and then start tightening, it should help... Dont tighten it too much or final outcome will be disastrous.... :)
  4. Tron

    Tron Superiore

    yes romi, absolutely right! Over tightening of screw may lead to screw stuck in that plastic hole. As threading in plastic may get damaged due to pressure applied by you in wrong manner.
  5. jayadev

    jayadev Esperto

    Kannur, India
    Grande Punto 1.3 90 HP
    These scerws should not be tight fastened ,you keep turning until it stops ensuring that all threads are engaged in. else the plastics will be damaged.
  6. Italia-Linea

    Italia-Linea Staff Member Janitor

    if the threads are gone then use a teflon tape and then tighten it lightly.
  7. hello,tried what tron said. but it didn't help. I think the thread has gone. but I have never tightened it to extreme. And it is for the first time I have opened it. tried teflon ,but it also failed. what to do next?

    ---------- Post added at 09:59 PM ---------- Previous post was at 09:57 PM ----------

    dear italia linea, it failed...please suggest what to do next. I think it has been damaged by some careless service people.

    ---------- Post added at 10:05 PM ---------- Previous post was at 09:59 PM ----------

    Dear Tron, I think you misunderstood. the problem is not that of misalignment. what I mentioned is that the left screw is not at all tightening... its turning around and around but not coming to a stop. but its not loose also. Just not stop turning around when tightened.
  8. vIjAy_kHaSa

    vIjAy_kHaSa Esperto

    My cover screw too were free, I installed plastic white gitti (local term don't know what it's called technically) into the hole for screw and tightened them. Screws should not have used at all in such place, clips at several places would have better like in other cars.

    Happens when engine cover is hot and you remove or install the screw, let the engine cool before removing screws.

    Last edited: Nov 6, 2011
  9. hello vijay, thank you.. but i can't see your attached image. please help
  10. Tron

    Tron Superiore

    My bad brother. I think threads are gone only. Though can't refuse vijay_khasa's thought too. Try to fix it in early morning when your your car will be cold.
    Still not happening then one option only, use teflon tep till your screw holds up in that bore.(At your own risk though!)
    Or report it to TASS. I dont think they can do anything much more about this issue.

Share This Page