1. Introducing the smashing new Team FIAT T-Shirt !! To order yours click here : Team FIAT T-Shirt

AC feels weak

Discussion in 'Electrical Systems' started by theblack, Jun 1, 2012.

  1. theblack

    theblack Esperto

    I own a 09 model punto (Black color) and off late I noticed that the AC efficiency seems to have gone down.
    I got the pollen filter cleaned, I even checked the temp coming out of the vents with the AC on..
    It was between 5-6C . The shop fellow told me that this is normal and there is no need to get the gas filled.

    I'm just a bit concerned about this because I read a lot about many ownership reviews here and all seem to be happy with the AC ,while I'm not ::pP.

    Mine does not have ACC so what i generally do is to set the gauges to lowest temp possible , turn the blower to 1 and leave it..
    I dont want to use 2 or 3 speed on the blower..
    During evenings and nights this feels very adequate but in the mornings (30-32C) it feels rather useless ( at blower speed 1)
    I just want to know if this is the max i can expect if i set the blower to 1 or if this is an issue i should be looking into deeply.
    Anyone else is facing this and if at all this is an issue.
  2. Bala

    Bala Esperto

    Clean the pollen filter or change to the newer mesh filter.
  3. theblack

    theblack Esperto

    I have cleaned the filter just a week ago..
    I think i have the mesh filter only..

    ---------- Post added at 10:36 PM ---------- Previous post was at 10:34 PM ----------

    i dont think there could be a leak anywhere either becuase i tested with the temp as well and it stayed between 5-6C for nearly 10mins .. so there is no slow degradation of temp either...
    Mine is Emotion model so there is no AC upgrade either, I suspect?
  4. karan desai

    karan desai Superiore

    Morbi, Gujrat
    with both the vents facing you and outside temp between 30-32 it should work really well even at 1 fan speed. my ac works well even above 40 degrees which is very normal here.
  5. theblack

    theblack Esperto

    With both vents to my Side there is no problem but with only one facing new, its not the case
  6. vIjAy_kHaSa

    vIjAy_kHaSa Esperto

    I think your AC is low on gas as my Linea vent temp drops to 3.2 C after 10 mins when ASS test it inside their workshop with outside temp around 35 C and @ 2000rpm with blower on med speed on ACC. Yours should be no different. The AC cuts @ 3C to prevent ice formation. With a large cabin the Punto/linea do take sometime to cool the car completely but cabin gets comfortable within 5 mins

    2009 MJD's have a different condenser (not sure) and a different Radiator Fan (100% sure). 2009 cars have Rad Part No 51785225 while cars after Sept/Oct 2010 have 51785226 the uprated Fan with higher CFM rating to take more heat out of condenser and radiator. Do you have any sticker placed on your Condenser stating Fiat part no. my car lost that while washing please share the part no if your car have that
    Fiat eper states that 51785227 is the condenser which is used after AC Upgrade Kit in Diesels with no info on old condenser part no. The chillness in 2010/2011 cars is better in extreme heat conditions.
    But this effects cooling only when Car is standstill or in heavy traffic and gets insufficient flow of air to condenser and temp is above 40C. On the open road the AC cools pretty good with no difference between old and new AC kit.
    As usual no reply from Fiat customer care on this matter after I sent them a mail so living with this issue.
    Last edited: Jun 2, 2012
  7. theblack

    theblack Esperto

    The cabin temp was not checked but the air from the vents was at 5c
    Will get it checked again from TASS and see if there its an issue.
    Also from what I can see there is no number on the condenser..
    When I get bumper I will check again

Share This Page