1. Introducing the smashing new Team FIAT T-Shirt !! To order yours click here : Team FIAT T-Shirt

AC compressor running but not blowing cold air

Discussion in 'Electrical Systems' started by avnsiva, Sep 13, 2016.

  1. avnsiva

    avnsiva Amatore

    Messages:
    140
    Chennai
    Had parked my Linea without use for around 20 days.

    On Sunday, had taken it and after driving for 30 km and then switched on the AC. To my surprise, the AC is not blowing any chilled air. The heating part is working though.

    Found an AC mechanic nearby and checked with him. There are 2 AC tubes valves in the engine bay. One underneath the coolant tank and the other which is left of the coolant tank.
    He removed the coolant tank and fixed the gauge underneath it. It shows 4 BAR (40-50 psi) of pressure.
    He said that there is no Gas and needs to refill it.

    My doubt is whether the leak is ruled out here? I assume that if there is a leak, both the High Pressure and Low Pressure gagues would read zero. Am I Right?

    I refilled the refrigerant 2 years before. It was working 20 days back and all of a sudden there is no gas. What would have happened to it?

    Shall I go ahead and refill the gas without checking for leaks (vacuum check..)?
  2. avnsiva

    avnsiva Amatore

    Messages:
    140
    Chennai
    Guys pls help.

    Sent from my Letv X500 using Tapatalk
  3. Ganges

    Ganges Esperto

    Messages:
    3,121
    Driver Seat _/
    :
    Grande Punto 1.3
    When my car was new, the problem was same not blowing cold air.Later found that issue was with O-ring.This was replaced, since then no issues.Actually this problem was there for most of 2011 batch cars.Dont know if the same problem is with your car.if the check has already been done with o ring then you may ignore it.
  4. vivek_lko

    vivek_lko Amatore

    Messages:
    237
    Noida
    @avnsiva same problem was there in my 2010 Punto . They replaced the Oring before but again after a few days the same issue . This was ultimately diagnosed by FASS(Kashyap Noida) as a leak in the copper coil . Luckily for me the same got replaced under extended warranty almost 3 years back . After that it started chilling superbly event at 46deg and above in Delhi summer. This is a long work and had to leave the car in FASS for 2 days but ultimately it was fixed properly.
  5. avnsiva

    avnsiva Amatore

    Messages:
    140
    Chennai
    So if there is a leak in the system, there won't be pressure retained on both High Pressure and Low Pressure side right?

    Its confusing that in Low Pressure, the guage showed 4 Bar pressure. But the AC mechanic did not check the High Pressure side. He says that if there is a leak, the Low Pressure guage will also show 0.
  6. avnsiva

    avnsiva Amatore

    Messages:
    140
    Chennai
    Took the car to Guru AC Mechanic shop in CIT Nagar Chennai on last week of October. Filled the tubes with normal air and left it for 3 days. THe pressure remained at 110 psi.
    So decided that there is no leak and filled with Freon Gas. It was cooling for a while and then again it stopped cooling. But the pressure is still there.

    Doubting with expansion valve. If not I guess I have to replace the compressor.

Share This Page